Oracle SOA Suite 11g, wrong settings after re-installation of SOA domain

During my installation of the 11g SOA Suite, things go bad once in a while and domains need to be created and removed, etc.

After last remove and new installation of my domain i got the next error message during startup of the Admin Server :

javax.transaction.SystemException:
weblogic.transaction.loggingresource.LoggingResourceException:
java.sql.SQLException: JDBC LLR, table verify failed for table 'WL_LLR_ADMINSERVER', row
'JDBC LLR Domain//Server' record had unexpected value 'soa11g_new_domain//AdminServer' expected
'soa_domain//AdminServer'*** ONLY the original domain and server that creates an LLR table
may access it ***

Easy fix would be :

Start sqlplus and connect to ‘DEV_SOAINFRA’ schema.

update WL_LLR_ADMINSERVER
set    RECORDSTR = 'soa_domain//AdminServer'
where  XIDSTR    = 'JDBC LLR Domain//Server';

commit;

Original blog

Share this Post:
Digg Google Bookmarks reddit Mixx StumbleUpon Technorati Yahoo! Buzz DesignFloat Delicious BlinkList Furl

4 Responses to “Oracle SOA Suite 11g, wrong settings after re-installation of SOA domain”

commenter

Thanks ! This works for soa_server as well.

We had to modify external server address and listen address to these values.

commenter

Hey, thanks a lot for this solution. Worked like a charm. Even Oracle Discussion forums couldn’t solve this error. :(

commenter

Hello Eric

Thanks for the post. We saved lot of time.

Leave a Reply:

Name (required):
Mail (will not be published) (required):
Website:
Comment (required):
XHTML: You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>